Resolved
The issue has been resolved where Trybe was running slow with issues creating order, creating clients, searching and loading pages is fixed. We apologise for the disruption caused.
Identified
We've identified the cause of Trybe running slow with issues creating order, creating clients, searching and loading pages. We will let you know as soon as this is resolved.
Investigating
We're investigating reports of Trybe running slow with issues creating order, creating clients, searching and loading pages. This is raised with the tech team and we will keep you updated as soon as we have any news.