No components marked as affected
Resolved
The issue has been resolved, all April payments that were stuck in "Preparing" have now updated to "Succeeded" or "Failed" (if there was something preventing the payment being taken i.e. lack of funds).
Investigating
We're investigating reports of some April membership payments stuck in "Preparing". We'll keep you updated on this.