Resolved
This issue has been resolved. Payments are now successfully processing again for retail product orders. We apologise for the disruption caused.
Investigating
Some users have reported that when attempting to take payment for a retail product order, an error is displayed: "Something went wrong!".
This is only affecting Orders for Retail Products only.
These payments are still being recorded in Trybe, but an error is being displayed. We are currently investigating this issue and apologise for any inconvenience caused.