Resolved
The issue has been resolved. We apologise for the disruption caused. You will need to select the "Update now" button at the bottom of your screen for the fix to be released. If you have any queries please reach out to Support.
Identified
We've identified the cause of the issue and will release a fix as soon as possible.
Investigating
We're investigating reports of the calendar not showing any bookings for sites that are behind UTC timezone. In the meantime you can access your bookings via the Orders page and filter by item date.
Apologies for any inconvenience caused.