Summary
On 27 August 2026, the Trybe platform experienced an outage lasting approximately 19 minutes where around 75% of traffic was unable to access Trybe. No guest, booking, or other customer data was accessed, altered, or lost at any point during the incident.
Impact
Area What operators experienced
Platform access Unable to log in to Trybe
Calendars & bookings Unable to view or manage bookings
Booking engine Unable to view or book offerings
Timeline (BST)
Time
Event
16:57
Issue detected; investigation begins
16:59
Incident declared; status page updated
17:03
Root cause identified: issue was introduced in recent deployment
17:03 - 17:15
Engineers work on rolling back deployment
17:16
Service recovered; incident moved to monitoring
17:51
Incident closed
Root Cause
As part of a new feature being developed, a code change was introduced which performed an inefficient database query. Once deployed, it forced the database to search through a very large volume of records for each request, making every request far slower than normal.
Our application servers were left waiting on those slow requests. The backlog of requests grew, and each stuck request was holding open a connection to a separate database - which eventually hit its connection limit and stopped responding entirely. The result was a full outage of the platform.
Resolution
Once the cause was identified, our team worked quickly to isolate the pipeline and decouple the recovery process from the affected database service. We then safely completed the rollback and stabilised the platform.
We are currently performing deeper code analysis and testing a permanent resolution prior to re-deploying the feature.
Preventive Measures
Following this incident, we have reviewed the process that led to it and have made changes to reduce the likelihood of this happening again. The steps we have taken are:
• Our engineers’ development environments now have strict policies on queries that can be executed to help discover these issues before they reach the review stage.
• Our code review process now ensures any database queries added or modified are scrutinised specifically for performance.
• Our deployment process is no longer be dependent on a database connection.
• We are making changes so that a problem in one part of the platform cannot exhaust the resources other parts rely on.
If you would like more information on the steps we're taking, please contact your account manager or compliance@try.be and we're happy to discuss this with you directly.
Closing
We recognise the disruption this caused to your operations and your guests, and we apologise for the inconvenience. If you have questions about this incident or its impact on your property, please contact our support team.
Resolved
Summary
On 27 August 2026, the Trybe platform experienced an outage lasting approximately 19 minutes where around 75% of traffic was unable to access Trybe. No guest, booking, or other customer data was accessed, altered, or lost at any point during the incident.
Impact
Area What operators experienced
Platform access Unable to log in to Trybe
Calendars & bookings Unable to view or manage bookings
Booking engine Unable to view or book offerings
Timeline (BST)
Time
Event
16:57
Issue detected; investigation begins
16:59
Incident declared; status page updated
17:03
Root cause identified: issue was introduced in recent deployment
17:03 - 17:15
Engineers work on rolling back deployment
17:16
Service recovered; incident moved to monitoring
17:51
Incident closed
Root Cause
As part of a new feature being developed, a code change was introduced which performed an inefficient database query. Once deployed, it forced the database to search through a very large volume of records for each request, making every request far slower than normal.
Our application servers were left waiting on those slow requests. The backlog of requests grew, and each stuck request was holding open a connection to a separate database - which eventually hit its connection limit and stopped responding entirely. The result was a full outage of the platform.
Resolution
Once the cause was identified, our team worked quickly to isolate the pipeline and decouple the recovery process from the affected database service. We then safely completed the rollback and stabilised the platform.
We are currently performing deeper code analysis and testing a permanent resolution prior to re-deploying the feature.
Preventive Measures
Following this incident, we have reviewed the process that led to it and have made changes to reduce the likelihood of this happening again. The steps we have taken are:
• Our engineers’ development environments now have strict policies on queries that can be executed to help discover these issues before they reach the review stage.
• Our code review process now ensures any database queries added or modified are scrutinised specifically for performance.
• Our deployment process is no longer be dependent on a database connection.
• We are making changes so that a problem in one part of the platform cannot exhaust the resources other parts rely on.
If you would like more information on the steps we're taking, please contact your account manager or compliance@try.be and we're happy to discuss this with you directly.
Closing
We recognise the disruption this caused to your operations and your guests, and we apologise for the inconvenience. If you have questions about this incident or its impact on your property, please contact our support team.
Resolved
After monitoring the fix, we can confirm the issue has been resolved. We apologise for the disruption caused.
Monitoring
A fix has been released and we’re monitoring the platform stability closely before confirming this is fully resolved. Thanks for your patience.
Investigating
We're investigating reports of Trybe not loading. Apologies for any inconvenience, we will keep you updated once we hear back